OpenWrt下VLAN的配置

想要改变你的路由器wan口和lan口配置或者添加wan口等就需要用到vlan配置

openwrt中的配置文件为/etc/config/network

如下将port0设置为wan口

    config switch_vlan  
              option device eth0  
              option vlan 0  
              option ports "1 2 3 4 5*"            #port1、2、3、4和cpu 5属于vlan 0  
      
    config switch_vlan  
              option device eth0  
              option vlan 1  
              option ports "0 5*"                    #port0和cpu 5属于vlan 1  
      
    config interface lan  
              option type     bridge  
              option ifname   eth0.0               #把vlan 0配置成lan口,即port1、2、3、4都是lan口了。  
              option proto    static  
              option ipaddr   192.168.0.168  
              option netmask  255.255.255.0  
              option gateway 192.168.0.1  
              option dns 192.168.0.1  
              option nat      1  
      
    config interface wan  
              option ifname eth0.1                  #把vlan 1配置成wan口,即port0就是wan口了。  
              option proto dhcp  

上面的配置文件只有一个wan口

如果想要增加一个wan口,需要再增加一个config switch_vlan,如下

    config switch_vlan  
              option device eth0  
              option vlan 0  
              option ports "1 2 3 5*"               #port1、2、3和cpu 5属于vlan 0  
      
    config switch_vlan  
              option device eth0  
              option vlan 1  
              option ports "0 5*"                    #port0和cpu 5属于vlan 1  
      
    config switch_vlan  
              option device eth0  
              option vlan 2  
              option ports "4 5*"                    #port4和cpu 5属于vlan 2  
      
    config interface wan2  
              option ifname eth0.2                 #把vlan 2配置成wan2口,即port4就是wan2了  
              option proto dhcp  

当然wan口增加了一个,lan口就要减少一个。

配置这个的方法也可以看luci页面的额配置,更加直观。

本文章由作者:佐须之男 整理编辑,原文地址: OpenWrt下VLAN的配置
本站的文章和资源来自互联网或者站长的原创,按照 CC BY -NC -SA 3.0 CN协议发布和共享,转载或引用本站文章应遵循相同协议。如果有侵犯版权的资 源请尽快联系站长,我们会在24h内删除有争议的资源。欢迎大家多多交流,期待共同学习进步。
分享到:更多

相关推荐

网友评论(0)